Offtopica Forums

This is a sample guest message. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

vBulletin 5.6.4 Release Candidate 3 is now available for download.

<p>The preview version of vBulletin 5.6.4 Release Candidate 1 is now available for download.</p>
<h2>Front End Changes</h2>
<h3>Lightbox</h3>
<p>The attachment system now uses the Lightbox display for all image content uploaded to the server. If the user has permission to view image thumbnails but not Images, then the lightbox will only show thumbnails. When clicking on the &quot;More Photos&quot; link in a Photo Gallery, the lightbox will be displayed appropriately.</p>
<p>In addition to this, the code for the lightbox has been updated and had several fixes applied. These fixes should allow for more accurate scrolling and the ability to select the last image in the list correctly.</p>
<h3>Photos Tab</h3>
<p>The Topic display now includes a Photos tab. This tab will open a gallery view of gallery and photo attachments within the topic and allow users to view them in a paginated format.</p>
<h3>Media Albums</h3>
<p>Along with the general lightbox updates, Media Albums within the user profile now support proper pagination.</p>
<h3>Other Issues</h3>
<ul>
<li>The system correctly inserts the Meta Tag to discover the XML sitemap better if you do not have it added to your custom robots.txt file.</li>
<li>CSS has been added for the proper highlighting of search keywords in search results. You can change the background color used here with the <code>search_result_highlight_color</code> style variable.</li>
<li>The browser should no longer attempt to submit the login form if Javascript is not functioning.</li>
<li>Modules should properly create channel lists within their options again.</li>
</ul>
<h3>PHP Module</h3>
<p>The PHP Module is no longer available. Please use a custom API and the Display Template module to replace this functionality. For more information on implementing these changes, see this article:
https://forum.vbulletin.com/node/4445230</p>
<hr>
<h2>Back End / AdminCP Changes</h2>
<h3>Template Processing</h3>
<ul>
<li>Removed the ability to <code>{vb:raw var.{vb:raw subvar}}</code> from template syntax. The accepted format is <code>{vb:raw var.$subvar}</code>. Any template modifications using the former will need to be updated.</li>
<li>Removed obsolete {vb:link} template directive. The proper directive to use is {vb:url}.</li>
</ul>
<h3>Database Updates</h3>
<ul>
<li>The <code>user.status</code> field is now in the <code>usertextfield</code> table. This change will help prevent rows in the user table exceeding MySQL's allowed row size.</li>
</ul>
<h3>Additional Issues</h3>
<ul>
<li>Updated the processing of custom CDN URLs so that CSS and SVG files work correctly again.</li>
</ul>
<hr>
<h2>Additional Information</h2>
<h3>PHP 8</h3>
<p>PHP 8 is due to be released in December 2020. At this time, vBulletin 5.6.X is not compatible with this version of PHP. There is ongoing development to ensure that compatibility with PHP 8 will be available before it is released.</p>
<h3>Install / Upgrade Instructions</h3>
<ul>
<li><a href="https://www.vbulletin.com/forum/node/4391348">Installation Instructions</a></li>
<li><a href="https://www.vbulletin.com/forum/node/4391346">Upgrade Instructions</a></li>
</ul>
<h3>File Cleanup</h3>
<p>After upgrading your vBulletin system, you should delete any possible obsolete files. You can obtain more information on why this is needed and instructions on how to do this here: <a href="https://www.vbulletin.com/forum/node/4391346"><strong>topic</strong></a> in the vBulletin 5 Installs &amp; Upgrades forum.</p>
<h3>System Requirements</h3>
<p>Minimum System Requirements</p>
<ul>
<li>PHP Version: 7.2.0</li>
<li>MySQL Version: 5.6.10</li>
<li>MariaDB Version: 10.1.0</li>
</ul>
<p>Recommended System Requirements</p>
<ul>
<li>PHP Version: 7.3 or higher</li>
<li>MySQL Version: 8.0 or higher</li>
<li>MariaDB Version: 10.3+</li>
</ul>
<p>For more information, see <a href="https://www.vbulletin.com/forum/node/4391344">vBulletin Connect System Requirements</a>.</p>
<h3>Current Version Support Schedule</h3>
<ul>
<li>Active Version - 5.6.3</li>
<li>Security Patch - 5.6.2</li>
<li>Security Patch - 5.6.1</li>
<li>No Patch Release - 5.6.0 and earlier</li>
</ul>
<h3>Discussion</h3>
<p>If you have any questions about these changes, you may discuss them here: https://forum.vbulletin.com/node/4447746</p>
<p>If you find an issue with the software or wish to place a feature request, please visit our <a href="https://tracker.vbulletin.com">tracker</a>.</p>
<p>To receive support for your vBulletin Product, please visit our <a href="https://www.vbulletin.com/forum/">community forums</a>.</p>

Continue reading...
 
Top